Ava-335: DoS of Ava Aware via API

Release Date

2nd December 2020.

Overview

An Ava Aware user without permissions to view alarms could perform a denial-of-service attack by repeatedly using an API that would cause Ava Aware to restart.

Affected Products

  • Ava Aware:
    • All Stable Upgrade Channel versions before 3.2.3.
    • All Beta Upgrade Channel versions before 3.2.3.

Unaffected Products

  • Ava Aware:
    • All Stable Upgrade Channel versions after and including 3.2.3.
    • All Beta Upgrade Channel versions after and including 3.2.3.
  • Ava Cameras: All versions
  • Ava Cloud: All versions

Resolution

This issue has been fixed in Ava Aware Beta upgrade channel version 3.2.3 and Stable upgrade channel version 3.2.3.

We recommend that all installations running an affected version upgrade to the latest release as soon as possible. Releases are available to download through the Ava Aware User Interface.

Vulnerability Information

Mitigations

There are no known mitigations for this issue.

Work arounds

The work around to this issue is to give all Ava Aware users permissions to view alarms in at least one device group or device site.

Acknowledgements

Issue found internally by Ava Security.

Disclosure Timeline

  • 27/11/2020 Issue found internally by Ava Security
  • 27/11/2020 Root cause established
  • 27/11/2020 Fix identified
  • 02/12/2020 Patched Ava Aware (Beta upgrade channel) released
  • 02/12/2020 Patched Ava Aware (Stable upgrade channel) released
  • 02/12/2020 Vulnerability publicly disclosed